Coding Guidelines

What do we want for the coding outlines/layout? These are open to discussion

General
Do not use abbreviations

For Java
Use javaDoc comments

Keep properties private - use get and set methods

Like this?

this.is.a.package
ThisIsAClass
THIS_IS_A_CONSTANT
thisIsAMethod()
thisIsAVariable
public void setSomething(String something)
{
        this.something = something
 [tab]  if(this.else)
        {
          [tab] somethingElse();
        }
}

Package naming - maybe something like ca.gridx1.sp.[package name]

-- ChrisUsher - 21 Mar 2006


This topic: HEPrc > WebHome > CodingGuideLines
Topic revision: r2 - 2006-04-26 - AndreCharbonneau
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback